Version Mismatch Error

If you are experiencing a Version Mismatch Error when attempting to play with your friends, it means that you and your friends are playing different versions of the game. This most commonly occurs after a new patch has been released.

To resolve this issue please ensure both you and your friends are updated to the most recent version of Dead by Daylight. You can check which game version you are on when looking at the title screen. 

 

 

Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Article is closed for comments.